Zeszyty Naukowe Uniwersytetu Szczecińskiego. Studia Informatica
Currently: Studia Informatica Pomerania
Kierowanie i przenoszenie wiadomości przez statki powietrzne w niespójnych sieciach DTN opierając się na informacjach o trasie lotu
(Message routing based on information about flight routes for delay tollerant networks)
DOI: 10.18276/si.2015.36-12
Cite
The full text is available
| ISSN: | 0867-1753 |
| eISSN: | 2300-410X |
| Authors: |
Radosław
Myśliński
Politechnika Warszawska Radosław Schoeneich Politechnika Warszawska |
| Keywords: | ad-hoc networks DTN networks routing protocol message ferrying |
| Issue / book publication date: | 2015 |
| Page range: | 11 (165-175) |
| OAI-PMH: | Metadata |
Abstract
The paper presents routing protocol designed for wireless Delay and Disruptive Tollerant Networks (DTN). The DTN network uses the storage-carry-forward paradigm for message delivery to the destination nodes using mobile message ferries. The proposed solution is designed to operate in a specific environment, where aircrafts are playing the role of message carriers. For the algorithm purpose, we assume the use of pre-defined information about the routes and time of airplanes movement, so-called flight plans. Additionally we assume no other communication possibilities.
Preview PDF
Bibliography
- Camara D., Loureiro A. (2001), GPS/Ant-Like Routing in Ad Hoc Networks, „Telecommunication Systems”, no. 18, s. 85–100.
- Cerf V., Burleigh S., Hooke A., Torgerson L., Durst R., Scott K., Fall K., Weiss H. (2007), RFC 4838 Delay-Tolerant Networking Architecture.
- Clausen T., Jacquet P. (2003), Optimized Link State Routing Protocol (OLSR). Farrell S., Cahill V. (2006), Delay-and Disruption-Tolerant Networking, „Artech House”, no. 9.
- Gerla M., Hong X., Pei G., (2002), Fisheye State Routing Protocol (FSR) for Ad Hoc Networks.
- Johnson D., Hu Y., Maltz D. (2007), RFC 4728, The Dynamic Source Routing Protocol (DSR) for Mobile ad-hoc Networks for IPv4.
- Karp B., Kung H.T. (2000), GPSR: GreedyPerimeterStateless Routing fo Wireless Networks, MobiCom.
- Liao W.H., Sheu J. P. (2001), GRID: A FullyLocation-Aware Routing Protocol for Mobile Ad Hoc Networks, „Telecommunication Systems”, vol. 18, no. 1–3, s. 37–60.
- Paruchuri V., Durresi A., Dash D., Jain R., Optimal Flooding Protocol for Routing in Adhoc Networks, www.cse.wustl.edu/~jain/papers/ftp/flooding.pdf (27.07.2015).
- Perkins C. (2006), Destination-Sequenced Distance Vector (DSDV) Protocol.
- Perkins C., Belding-Royer E., Das S. (2003), RFC 3561, Ad-hoc On-Demand Distance Vector (AODV) Routing.
- Young-Bae K., Vaidya N. (2000), Location-Aided Routing (LAR) in mobile ad hoc networks, „Wireless Networks”, no. 6, s. 307–321.
- www.filghtradar24.com (27.07.2015).

